思威电邮LOGO
有退信,用中继
 
 
 
当前位置
文章正文
Exchange OWA 显示异常的相关解决方案
www.email-cm.com    2013-09-10 10:26:33    文字:【】【】【
摘要:Exchange OWA 显示异常的相关解决方案

      在 Exchange 2003 的 OWA 中经常会遇到一些显示异常的问题,这些问题大多体现在 Exchange 服务器的前端 Web 服务器 IIS 服务器,本文以一些特定的环境为前提希望也同时可以解决你的 OWA 相关的问题。

 

 当从一台XP客户端通过OWA进行访问时,如直接通过后端http://sbs1/exchange访问则无任何问题。

    但如通过前端http://denver/exchange访问则可以进入邮箱,但无法进行操作,且显示不正常。

    然后到前端服务器本机上去访问也是相同情况。去掉前端IE增强安全性也是一样。

    下图为将denver设置为前端:

   

Snap1

 

    XP客户端通过OWA访问前端时出现乱码。

   

Snap4

 

    XP客户端通过OWA访问后端时正常。

   

Snap3

 

    思考一:IIS有问题么?
    测试:在前端服务器上去掉了前端功能,然后在上面建立了一个网站,XP客户端访问时网页显示完全正常。
    结论:所以可以确定前端上的IIS是没有问题的。


    思考二:IIS没有问题,那么系统和安装源源文件有没有问题呢?
    测试:重新安装一台Windows Server 2003 R2虚拟机,IIS也全部全新进行了安装,然后再安装Exchange2003(在安装时采用的所有源文件同后端服务器相同)。安装成功后,再将其设置为前端,出现了同样乱码问题。
    结论:IIS没有问题,Windows安装源文件和Exchange安装源文件都也没问题。


    思考三:
    在Windows系统、IIS以及Exchange安装和设置都没问题的情况下,一旦设置成前端就会出现了OWA乱码现象。在网上搜索也有很多相问题的求救?
    我们知道,在安装第一台exchange服务器时需要作森林的扩展和域的扩展。在同一个森林中森林扩展一次就够了,同一个域中理论上域扩展也只需要作一次,对于新安装在相同域的其它exchange服务器上是可以不做的。
    但经过前面的测试,能够怀疑的就只剩下域扩展和补丁两个方面了。


    提出解决方案:
    在denver上重新作一次域扩展,然后再打一次exchange 2003 sp2的补丁。

 

 实施过程如下:
    1、在denver上重作域扩展。

  

Snap5

Snap8 

 

    2、域扩展成功后,再安装exchange 2003 sp2补丁。补丁的下载链接为:http://download.microsoft.com/download/2/c/6/2c6e0453-49b5-4a03-8bd3-f8546a0f8dc7/E3SP2CHS.EXE

  

Snap10

Snap11 

 

    3、重启dever。
    4、重启后在XP客户端用OWA方式重新访问邮箱,从下图可见不再有乱码了。问题解决!!!

   

Snap16

 

    小结:
    Exchange 2003前端服务器OWA 访问显示异常最佳解决方案为:重新域扩展+Exchange 2003 sp2补丁。

     原文转载自思威电邮,转载请标注,谢谢!

浏览 (401) | 评论 (0) | 评分(0) | 支持(0) | 反对(0) | 发布人:管理员
将本文加入收藏夹
联系方式

电话:18321295370
传真:021-51684215
在线客服:点击这里给我发消息

邮件技术群:海外邮件退信

脚注信息

电话:021-54489915-8004    传真:021-51862615
Copyright(C)2001-2013 上海云盟信息科技有限公司 沪ICP备12048411号-1

 

Error: Fold (./) is not writable